Các lệnh cấu hình cơ bản Cisco Catalyst

Thứ sáu - 21/07/2023 05:09 259 0
Các lệnh cơ bản cấu hình mới thiết bị Cisco Catalyst
Các lệnh cấu hình cơ bản Cisco Catalyst
Đặt host name
Switch(config)#hostname ASW-location-01 (ex: ASW-A2-L1-01)

Cấu hình VTP
ASW-location-01(config)# vtp mode server
ASW-location-01(config)# vtp mode client
ASW-location-01(config)# vtp domain string
ASW-location-01(config)# vtp password string

Cấu hình Timezone
ASW-location-01(config)# clock timezone GMT +7
ASW-location-01(config)# ntp server 10.1.18.13

Cấu hình SNMP
ASW-location-01(config)# snmp-server community snmp_string RO
ASW-location-01(config)# snmp-server community snmp_string RW
Chỉ gởi thông tin SNMP tới một địa chỉ máy chủ
ASW-location-01(config)# snmp-server enable traps
ASW-location-01(config)# snmp-server host 172.30.2.160 snmp_string snmp envmon
ASW-location-01(config)# snmp-server host 172.30.2.160 snmp_string snmp syslog


Cấu hình mã hóa mật khẩu
ASW-location-01(config)#service password-encryption

Tạo user và gán quyền cho user
ASW-location-01(config)# username admin privilege 15 password mat_khau_admin
ASW-location-01(config)# username view01 privilege 7 password mat_khau_view

Thay đổi đặc quyền của lệnh clear countersreload từ 15 xuống 7 để cho user view01 có thể sử dụng
ASW-location-01(config)# privilege exec level 7 clear counters
ASW-location-01(config)# privilege exec level 7 reload

Tạo RSA key sử dụng SSH
ASW-location-01(config)# crypto key generate rsa general-keys label keyabc modulus 1024

Cho phép remote kết nối
ASW-location-01(config)# line vty 0 4
ASW-location-01(config-line)# login local
ASW-location-01(config-line)# transport input ssh telnet
ASW-location-01(config-line)# end

Cấu hình port trunk
ASW-location-01(config)# interface g1/0/24
ASW-location-01(config-if)# switchport mode trunk
ASW-location-01(config-if)# end

Kiểm tra VLAN
ASW-location-01# show vlan

Gán IP vào interface VLAN
ASW-location-01(config)# interface vlan 12
ASW-location-01(config-if)# ip add 192.168.1.10 255.255.252.0
ASW-location-01(config-if)# no shut
ASW-location-01(config-if)# exit

Cấu hình Routing
ASW-location-01(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

Cấu hình DNS Server
ASW-location-01(config-if)# ip name-server 8.8.8.8

Test ping ve 192.168.1.1
ASW-location-01 # ping 192.168.1.1

Gan port access cho switch
ASW-location-01(config)# interface rang g1/0/1-22
ASW-location-01(config-if)# sw mode acc
ASW-location-01(config-if)# sw access vlan 71
ASW-location-01(config-if)# end

Cấu hình lịch chạy backup
ASW-location-01(config)# kron occurrence BackupConfig at 16:56 recurring
ASW-location-01(config-kron-occurrence)# policy-list BackupConfig
ASW-location-01(config-kron-occurrence)# exit
ASW-location-01(config)# kron policy-list BackupConfig
ASW-location-01(config-kron-policy)# cli copy running-config tftp://192.168.1.30/it-room/startup_config.cfg
ASW-location-01(config-kron-policy)# exit

Cấu hình lịch chạy backup tạo file backup theo ngày giờ
ASW-location-01(config)# archive
ASW-location-01(config-archive)# path tftp://192.168.1.30/it-room/$h-$t
ASW-location-01(config-archive)# exit

ASW-location-01(config)# kron occurrence Backup at 15:28 Tue recurring
ASW-location-01(config-kron-occurrence)# policy-list Backup
ASW-location-01(config-kron-occurrence)# exit

ASW-location-01(config)# kron policy-list Backup
ASW-location-01(config-kron-policy)# cli archive config
ASW-location-01(config-kron-policy)# exit

Cấu hình Syslog Server
ASW-location-01(config)# logging discriminator nolog msg-body drops flapping  (không gởi các thông tin flaping MAC address)
ASW-location-01(config)# service timestamps log datetime msec localtime show-timezone
ASW-location-01(config)# hw-switch switch 1 logging onboard message level 3
ASW-location-01(config)# hw-switch switch 2 logging onboard message level 3
ASW-location-01(config)# logging source-interface Vlan12    // cau hinh nguon cap
ASW-location-01(config)# logging trap  3
ASW-location-01(config)# logging host 192.168.1.8
ASW-location-01(config)# logging host 192.168.1.23
ASW-location-01(config)# logging host 192.168.1.8 transport udp port 515

Chỉnh định thiết bị làm root spanning tree cho VLAN
ASW-location-01(config)# spanning-tree vlan 12 root primary
hoặc dùng cho range vlan
ASW-location-01(config)# spanning-tree vlan 1-5,11-12,16-25,30-32,46,48,50-51,60-72,100 root primary

Lưu cấu hình
ASW-location-01# wr
ASW-location-01# copy run start

Tổng số điểm của bài viết là: 0 trong 0 đánh giá

Click để đánh giá bài viết
Bạn đã không sử dụng Site, Bấm vào đây để duy trì trạng thái đăng nhập. Thời gian chờ: 60 giây